Raspberry-pi 3 minicom –b 115200 –D /dev/ttyACM0 access denied

Solved
airFBR's picture
airFBR
Junior(0)

Hi I am adding ATT starter kit to raspberry pi 3 working with raspberry strech (v 9.3)

I am following the instructions on file titled "LTE IoT Add-on Kit for Raspberry Pi 3
- Getting Started Guide -"

when trying to acsess minicim

minicom –b 115200 –D /dev/ttyACM0

showes:

minicom: cannot open /dev/tty8: Permission denied

Any suggestions?

Hi, the problem is that minicom is trying to open '/dev/tty8' not '/dev/ttyACM0'.  That is the reason for the failure. I suggest you start minicom with the '-s' flag and set up the configuratioin as necessary.  That approach may work.  Are you sure that the board is connecting as /dev/ttyACM0?

bingatang1876's picture
bingatang1876
Junior(0)

Though I'm still having connection troubles to the network due to other issues,

I did get my add-on kit running with raspbian stretch to at least respond to AT commands by 1. using:

sudo minicom -s

then go use the arrows to select serial port setup

replace where it says /dev/tty8 with /dev/ACM0

hit enter,

choose save setup as dfl

reboot the modem , etc.

alas mine still needs to run the command as root using sudo minicom –b 115200 –D /dev/ttyACM0

but it does respond to AT commands after that. Now I just want to see if I can get it on a the network. I may just have to boost some cell signals.

 

bingatang1876's picture
bingatang1876
Junior(0)

Yep, I'm done with this thing for my raspberry pi solutions,  so very very poor, I just wanted to connect my machines to my code via a cellular network, I think I'll be going with a skywire solution for my stuff, and leave this device as a paper-weight, when I saw that they can't even install a security cert (in the age of let's encrypt) on a support site-that requests credentials, well, that's telling. I write off that 70 bucks.

skorpeo's picture
skorpeo
Junior(1)

This board his heavily restricted, see my question here: http://cloudconnectkits.org/forum/topic/global-iot-modem-m18qwg.  Unlike the first generation that worked smoothly with a raspberry pi this version is handicapped with false advertising to boot.

the requirement for sudo when using minicom is a linux thing.  Check out https://spremi.wordpress.com/2012/01/10/minicom-enable-access-to-normal-... which may help.

Did you run though the tutorial for connecting to the network. There is a series of steps that you have to perform to enable the board onto the AT&T network.  Since I don't know what you are trying to do, I'm not able to offer much help.

xuvamy's picture
xuvamy
Junior(0)

All the reforms of the current students have been done for the humans. The intellectuals and costom writing have been produced with the best attitude of the persons for the future moves.