Previously Unseen Compile Errors AWS demo

Solved
jrecchio's picture
jrecchio
Junior(1)

I've been working on the non-modem related portion of my project in its own program for a couple weeks. I went back to my ATT_AWS_IOT_demo project and found a list of errors that I hadn't seen before. I thought maybe I modified something by accident so I tried to re-import a pristine version of the ATT_AWS_IOT_demo project from mbed, but I have found the same errors are present even when trying to compile this.  Has the project broken for anyone else when using the mbed online compiler? I'm not sure what I'm missing at the moment. Here is a link to an image of the errors since I can't seem to embed pictures here. 

 

jrecchio's picture
jrecchio
Junior(1)
LightCollector's picture
LightCollector
Moderator(20)

Hi,  First off I am not familiar with the AWS project but I will pass this along to those that are.  2nd, I do think though the issue arises because ARM has changed the compiler used in the online tools.  For the original StarterKit libraries we've seen a bunch of warnings as well.

 

Best regards!

jrecchio's picture
jrecchio
Junior(1)

I just re-ran the same programs this morning and they all compiled without the errors.  I guess it was something that ARM changed on their mbed compiler. 

LightCollector's picture
LightCollector
Moderator(20)

Glad to hear it is now working for you!  Sorry about the ARM tools, lots of dependancies in these kits that we can't directly control.

 

Best regards
 

LightCollector's picture
LightCollector
Moderator(20)

Glad to hear it is now working for you!  Sorry about the ARM tools, lots of dependancies in these kits that we can't directly control.

 

Best regards