? Latest Firmware Update Cat M and LTE - Avnet/AT&T WNC 14A2A

Solved
rmarlan's picture
rmarlan
Junior(0)

I am trying to locate the latest firmware for the Avnet/AT&T WNC 14A2A.  I see the update manual referncing NQ_MPSS_IMA3_v10.58.174043 (LTE-M) and CM_MPSS_M14A2A_v11.50.164451 (LTE).  But I also found a refernce to CM_MPSS_M14A2A_v11.50.171541.  I dont know if 171541 is for LTE-M or LTE.

Is there a central site for latest firmware?

I am using 174043 to connect LTE-M.  My issue in a strong signal area sometimes it will connect fine. 

AT+CSQ                                                                          

+CSQ: 14,99

 At other times it will not connect at all .

AT+CSQ                                                                          

+CSQ: 99,99

.  I have tried hardware powercycle of the module that does not help.  I have checked and verified the SIM status and the APN. 

AT+CGDCONT?                                                                     

+CGDCONT: 1,"IP","m2m.com.attz",,0,0,0,0,0,,0

I have verified that the LTE-M device itself is not connecting - it is not an issue of the raspberry pi getting the IP address.  

Thanks for your help.

Robert

jflynn129's picture
jflynn129
Moderator(2)

firmware and the instructions are maintained by AT&T. They can be found here:
https://s3-us-west-2.amazonaws.com/starterkit-assets/LTE-M.Firmware.Upgrade.Guide.pdf

The two versions of firmware mentioned in that document are currently the only supported versions I believe.