HW compatible details

Solved
Harishk_2k's picture
Harishk_2k
Junior(0)

Hi,

I am from GE and we are developing apps based on IOT modem (Model: M14A2A).  Along with this modem we got FRDM hardware to interact with WNC hardware. 

We need following queries

1. We have followed steps provided in "AT&T Cellular IOT Starter Kit Quick Start Card" until step 10 everything worked. We have setup the port as per step 8. But step 11 suppose to give some serial output in console. But we are not seeing any console output. Please let us know why there are no logs? How do we communicate the FRDM hardware ? 

2. Is the WNC Arduino shield support Begalbone ? If it supported then we need some sample application to interact with Begalbone with WNC Arduino modem.

3. Is there are any sample application available for communication through modem ?

Thanks

Harish

LightCollector's picture
LightCollector
Moderator(20)

Hi,  Regarding # 1.  If you were able to program firmware and there are lights on each board.  Please double check the USB port you are using to connect the PC to the K64F USB port (which is multipurpose).  The proper serial USB port on the K64F board is same one used to program firmware into the K64F.

 

If the correct USB port is being used, you may have to double check if the proper drivers on your Windows or MAC were installed correctly.  Once that is done, using any terminal program (we recommend teraterm), you should see text information coming out from the K64F board.  The settings as outlined in the Quick Start Card are 115200,8,N,1.

 

If all of the above has already been done correctly, if you can, try to setup a different PC for the serial terminal access and try it.

 

Best Regards,

-Fred

Harishk_2k's picture
Harishk_2k
Junior(0)

Sure. We will try again and update the thread. Could you please reply to my rest of queries ?

Harishk_2k's picture
Harishk_2k
Junior(0)

Hi,

We have tried same procedure in Windows and linux machine. But we are not succeeded in any of the machine.  Other hardware like Begal Bone Black in my same Mac machine and it works perfectly with same USB cable. We are able to see the boot-up sequence and login getting successful with Begal Bone Board. 

This rules out machine issue.

 We are looking for faster technical support to meet our project schedule. Please let us know phone support to provide the technical solution. 

Looking for your reply ASAP.

Thanks
Harish

LightCollector's picture
LightCollector
Moderator(20)

Hi,  I answered which questions that I can, I am not versed in beaglebone hardware, sorry, others at Avnet may be but I am not.  The originator of this forum topic is a hardware person.  I just jumped on your question to try to help you with what I could.  I have been taking care of the software topics.  Of course I will ask my colleagues.

 

If you do not think that it is the serial connection, it may be that the board has not been programmed correctly with the application that you asked about for your 3rd question. 

 

One of the steps was to load in the application binary.  Is it possible it was not programmed correctly?

 

If the board was working (running the demo application) the RGB LED would turn RED after power-up and then go briefly BLUE (maybe to brief depending upon the quality of the cellular connection) and then should turn colors when rotating the board.  The app sends information to the ATT FLOW server.  Also of course the serial port will output information as you already know.  The link to the source code for the demo application is in the getting started guide section 6.

 

Best Regards,

-Fred

Harishk_2k's picture
Harishk_2k
Junior(0)

Hi,

Is it possible to provide some Application Engineer whom can help on this issue ? We have tried various methods but we are not able to see any console logs. 

Really appreciate your reply.

 

Thanks
Harish

fletch's picture
fletch
Moderator(0)

Regarding your question about support for the Avnet Shield on Beaglebone, we have not tried that yet. I assume that it should work, but it would depend on the correct peripherals aligning to the pinout on the Avnet Shield.

 

In terms of live support, that is only offered through our FAEs. Please contact your local Avnet branch to request support.

 

Bryan