Cellular Shield modem initialization always fail

Solved

I have trouble to make Cellular modem work. I have followed the instruction step by step to upgrade Firmware on NXP K64F Freedom Board and Avnet M14A2A Cellular Shield board.  I have also power up Cellular Shield board with external power supply with provided power cable. But everytime I have got message like below after I powered up. There is no connection issue except sim card slot may be loose. What else can cause this issue?

Send: <<AT+CSQ>>
[AT+CSQ+CSQ: 99,99OK]
Send: <<AT+CPIN?>>
[AT+CPIN?ERROR]
------------ software_init_mdm! --------->
Send: <<AT+CSQ>>
[AT+CSQ+CSQ: 99,99OK]
Send: <
       N?ERROR]
------------ software_ini----->
Send: <<AT+CSQ>>
CSQ+CSQ: 99,99OK]
Send: <<AT+CPIN?>>
[AT+CPIN?ERROR]
------------ software_init_mdm! --------->
Send: <<T+CSQ>>
[AT+CSQ+CSQ: 99,99OK]
Send: <AT+CPIN?>>
[AT+CPIN?ERROR]
------------ software_init_mdm! --------->
 

Thanks!

LightCollector's picture
LightCollector
Moderator(20)

Hi,  Sorry to hear you are having troubles with the kit.  The CPIN cmd error does indicate trouble with the SIM.  It could be the socket or the card.  Make sure the contacts that you can access are clean and the Shield board is well seated in the K64F board.  Power up the pair with the power supply usb cable attached to the Sheild 1st, then attach the K64F USB cable 2nd.  If you have another working kit to swap things with, you could narrow it down trying the different pieces.  Assuming you don't, you should contact where you got the kit from or your local Avnet FAE office to try and exchange the kit for another.

 

The software will not proceed until it gets an OK back from a sequence of checks to make sure it is setup and operating correctly.  The signal quality cmd is working so I suspect things are powered correctly and the serial connection is working but please recheck things.

 

Contact me if you can't get this resolved.

 

Best Regards

Hi,

The issue really is related with sim card slot. After figuring out how to secure the sim card, the issue resolved.

 

Thanks!