AT&T Iot Starter Kit (2 gen) WNC_ADB unauthorized

Solved
ckasky's picture
ckasky
Junior(0)

Hi,

Firstly thank you for reading my problem.

The problem is that, previously I used SK2 in a virtual machine (Ubuntu 16.04) in my Win10 laptop successfully, now I want to transfer the platform to raspberry pi3 with raspbian system. I did the exact same steps as what I did in the virtual machine, downloaded the AvnetWNCSDK package, pushed the adbkey.pub file to ~/home/XX/.android/ directory, then I entered "sudo adb devices", it says "WNC_ADB unauthorized". I tried kill-server and start-server many times, it was still the same. If I entered "adb shell", it says "This adb server's $ADB_VENDOR_KEYS is not set". I also add an 51-android.rules in directory ~/etc/udev/rules.d/, this problem is still there. But when I plugged SK2 back to virtual machine, it can be accepted and worked well. so I have no idea how to solve that. If anyone could help me. Thank you so much. 

Kevin

jflynn129's picture
jflynn129
Moderator(2)

You are the first to try and run the SK2 with a PI I think, officially, we have only verified support for Ubuntu.  That said, if Raspbian supports ADB (which I assume it does since it's a Linux based OS) it should work.  Given that it is reporting as "unauthorized", it seems that one of two things are the problem. (1) ADB wasn't started in supervisor mode (sudo adb devices) or (2) You didn't place the adbkey.pub file into a directory that adb.exe can find.  Did you try putting adbkey.pub into the same directory as adb.exe?

ronniekjr's picture
ronniekjr
Junior(0)

 

Kevin,

Were you able to resolve this issue. I'm attempting he same thing with same results you are getting. I am unable to move the adbkey.pub file to the directory that contains the adb.exe. I get this error   "cannot create regular file '/home/pi/usr/bin' : No such file or directory".  I'm really new at this. I would appreciate ant instights you may have gained.  There doesn't appear to be many people using the pi with SK2. Thank you

Ronnie

 

jflynn129's picture
jflynn129
Moderator(2)

I've not used the SK2 with a PI myself, but the reason for the error is that ADB cannot find the adbkey.pub file. You may try to do a 'sudo cp adbkey.pub ...' to the directory that contains adb.exe